SparrowDesk - Issues with loading SparrowDesk Application – Incident details

All systems operational

Issues with loading SparrowDesk Application

Resolved
Major outage
Started 24 days agoLasted 25 minutes

Affected

Application

Major outage from 11:45 AM to 12:10 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We have identified an issue with our CDN Provider which affects loading the SparrowDesk Application. We are investigating the issue